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1. Installing the website

You may find below information about the Car Portal integrated setup wizard, the description of the 
different steps, possible errors and troubleshooting information. 

The setup is quick and easy, it passes through just 3 steps – agreeing with the license agreement, 
entering the MySQL information (server, username and password) and selecting the database to be 
used for the installation.

Please note also that we offer free installation for all our products, so in a case you prefer that we do 
the installation for you, please just contact our support team and we'll do it as soon as possible for you

Step 1 - Welcome screen, license key and Car Portal end user license agreement

In this first step you'll be able to:
 see the  setup welcome message
 enter the license key you obtained during your purchase
 read the Car Portal end user license agreement

In order to continue to the next step, you'll have to enter the license key for the software obtained 
during the purchase and also agree with the Car Portal end user license agreement by clicking on the 
check box (“I agree ...”).
Entering a valid license key and clicking on the Continue button will redirect you to the second step, 
where you'll have to enter the MySQL server information.

Step 2 – Entering the MySQL server information (MySQL server, username and password)
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During this step you'll be able to enter the MySQL server information (the server name, MySQL user 
and password) of your host. The setup needs this information in order to be able to setup  the main 
database used by the Car Portal setup. 

In this step, you'll be asked to enter:

- MySQL Server – the server where you plan to install the database, usually “localhost” for most of the 
hosting companies or if installing it on your local computer

Please note that on some hosting companies like GoDaddy, the MySQL server name is specific for  
every database, which is created and looks like for example: db_name.db.11111.hostedresource.com
In such cases it's necessary to copy and paste the exact server name, which you may get from the  
hosting package control panel.

-MySQL username and password 

On most hosting package, you'll need first to create a new MySQL user and database from the hosting 
package control panel, so it's up to you to choose the password and username you prefer. 

Please note on Cpanel hosting package (used by the most popular hosting companies like HostGator,  
BlueHost, HostMonster, CirtexHosting etc.) if you create a new database and MySQL User you need  
to explicitly give permissions to this user for the database you created – you can do that from the  
MySQL Database page in Cpanel, at the bottom.

If you are not sure for these settings, please contact your hosting provider or log in to your hosting 
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package control panel,  where usually this information can be found on a page called “MySQL” or 
“Databases”.

After you enter these values and click on the Continue button, the setup will try to connect to the 
MySQL server with the user name and password you entered. If  any of values aren't correct (the 
address of the MySQL server or the MySQL user name and password), then an error message will be 
displayed and you won't be able to continue until you enter the correct values.

Troubleshooting

1. After you click the Continue button you receive an error message in red saying “Server doesn't 
exist or access is denied”.

If this is the case, please check once again the values you have entered. If the problem persists: 
– make sure that your MySQL server is up and running and that this account is valid
– make sure also you enter a correct MySQL server name (on companies like GoDaddy and 1&1 
the name isn't the default “localhost” and may be different for every database) 
– on CPanel hosting packages, please check if permissions for the database are granted to the 
MySQL user you entered
- if you have any troubles finding the correct MySQL information for your hosting package, you 
can also  contact your hosting provider and ask them for the MySQL settings for your hosting 
account

Step 3  - Setup of the main Car Portal database

In this step you'll be asked if you would like to create a new database for Car Portal or use an existing 
one. 

If you choose the option to create a new database, you'll be asked to enter the name of the database. 
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We recommend you to use a name, which will be easy to distinguish, like for example classified_ads. 
Be aware that when choosing this option, the MySQL user you have provided in the previous step 
should have the rights to create new databases on the MySQL server.  If  this is not the case, the 
database creation will fail and such error will be displayed on the screen.

If you choose the option to use an existent database, the Car Portal database tables will be created in 
the database chosen by you. All the tables, which will be created will have a prefix “netartmedia_”, no 
data from the existing database and tables will be deleted. 

Troubleshooting
1. I have  chosen the option to create a new database but when I click on Continue, I get an error 

message colored in red and I can't proceed to the next step, why?
- make sure that your MySQL user has “CREATE DATABASE” permissions on the MySQL server
- make sure that you don't have already a database on your server with the same name as the one 
you entered

2. I have tried to use the second option, to use an existing database, but I receive an error message 
saying that the table “netartmedia_admin_users” already exists
- this means that you have previously installed the script in this database, so you may either use a 
new database or delete the old script tables and then continue with the installation

Be aware that in this step the setup creates also the script configuration file. If the process running 
PHP on your server for your hosting package doesn't have right permissions in the folder where you 
install Car Portal you'll receive the following message in the interface:

The  process  running  PHP  on  this  computer  doesn't  have  permissions  to  create  and  write  the 
configuration file in the main web folder. You need to create it manually – the content will show up in 
the screen. You need to copy / paste it in a file “config.php” and upload it in the main web folder (the 
one in which you uploaded the real estate files). So you could either upload it with FTP or use the File 
Manager in your hosting package control panel to save the config.php file.

If you experience troubles when doing this or have any additional questions, please don't hesitate to 
contact us.

Step 4 – Installation successful screen

If you reached this step, Car Portal has been installed successfully on your server/hosting package 
and you can open the front site and also the administration panel to manage the website and different 
settings.

2. Configuring the website

2.1. Configuration options

The Settings->Configuration options in the administration panel provides functionality to manage the 
different options and settings on  the website. You may find below a list and description of the different 
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configuration options.

How to charge the users?
Using this setting you can set your preferences if you would like to charge the real estate agents using 
subscription or using credits or if the site should be free for all users. If you choose to charge them 
with subscriptions (recurring payments), you can create different subscription packages with different 
number of ads, featured ads and banners included in them and different pricing and let the users 
choose  the  subscription  they  prefer.  If  using  the credits  method,  the  real  estate  agents  need  to 
purchase credits and they can spend after these credits to pay for the different services offered on the 
website.

Ads expire in (days) 
With this setting you can control the number of days in which the posted ads on the website will  
expire. The default value is 30, but you can easily change it with another number of days you prefer.
If you set it to: -1 , then the ads posted on the website will never expire.

Enable SEO URLs 
The search engines optimized urls look like static html pages and have keywords in the url (which 
allows better indexing by search engines like Google).
In order to use the SEO links, the system will require the presence of the mod_rewrite module (for  
Linux /  Apche or isapi_rewrite for  Windows /  IIS).  If  this module is not present  on your server or 
hosting package, you could deactivate this feature by setting it to NO.

Auto validate the new listings 
If set to NO, the listings posted on the front site will need to be validated from the administrator before 
they show up on the front site.  The administrator  can see and approve the new listings from the 
Dashboard page of Ads Management in the administration panel

System Email Address 
You can set with it the system email address, which will appear as sender of the system emails sent 
by the website (like the email when the listings are approved etc.).

 
System Email From Field
The name of the sender of the system email address, which is used when sending email notifications, 
welcome emails and others to the users.

Send email when approving listings 
If set to YES, an email will be sent to the user once his listing is approved by the administrator. With 
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the settings below it's possible to set the email text and subject of the email message that will be sent.
 

Approve email subject 
This setting allows to modify the subject of the email that will be sent to the user when his listing is 
approved. The default text is “Your listing has been approved!” and can be changed with whatever 
different text the administrator may prefer.

 
Approve email text
This setting allows to modify the subject of the email that will be sent to the user when his listing is 
approved. The default text is:
“The listing you submitted

{LINK}

has been approved and added on our website.”

in which {LINK} will be replaced with the url of the listing.

Number of results per page 
By changing the value of this setting, you can control how many results will show up on the front site 
when the users make a search or browse the listings per make etc.
The default value is set to 10.

 
Number of category columns 
On the front page by default the categories show up in 3 columns – if you prefer another number like 4 
or 5 columns, you can easily set this by modifying the value of this setting.

 
Number of listings in Featured section 
Use this setting to control the number of featured listings, which will show up in the Featured Listings 
section to the right. Please note that if there are featured listings on the website than the available 
positions (number you set in this field), then the featured listings will show up randomly in the Featured 
Listings section

 
Message on successful new submission (free listings)
This is the message the user will see when their listing (website) has been submitted successfully. 

Message on successful new submission (paid listings)
Use this field and setting to modify the message that the users will see when submitting a paid listing. 
It's  a  separate and different  message than the free listings,  because often the administrator  can 
choose to include information specific for the paid listings (for example – your listing will be approved 
as soon as we receive your payment).

Website currency
By default this setting is set to the US dollar sign “$”, but you may change it to another one you prefer 
(like CHF or ).  This will change the currency symbol displayed next to the prices on the website.
This applies for all the prices of the listings on the website, pricing for posting listings and banners etc. 

 
Currency Code 
The PayPal currency code if the PayPal system is enabled. By default it's set to USD (US dollars), but  
can be changed to any other valid PayPal currency code like EUR, GBP etc.
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Use CAPTCHA images to prevent spamming 
A good way to avoid automatic form submissions when creating a web form is to add some kind of 
verification. One of the best ways is to use an image verification, called also captcha. What it does is  
to dynamically create an image with a random string displayed on it. Then visitor is asked to type that  
string in a text field and once the form is submitted it checks if the string on the image matches the 
one inputted by the user.
The usage of the captcha images is enabled by default, but if you would like to disable it (for example 
if the PHP graphics library - GD isn't installed on your website), you could change the value of this 
setting to “NO”.

 
Website time zone 
With this setting you can change the default  time zone on the website. The time zone coming by 
default for most of the downloads is Europe/London.
List of the supported time zones can be found on: http://www.php.net/manual/en/timezones.php

Some examples of supported time zones are:

America/Buenos_Aires 
America/Chicago 
America/Los_Angeles 
America/Mexico_City 
America/New_York
Asia/Singapore 
Asia/Tokyo
Europe/Berlin 
Europe/Madrid 
Europe/Moscow 
Europe/Zurich 
…

 
PayPal ID 
When the PayPal system is enabled, in this field, the administrator/website owner has to enter the 
PayPal account (registered PayPal email address) he would like to use to charge the users on the 
website.

 
2checkout ID 
When the 2checkout system is enabled, in this field, the administrator/website owner has to enter the 
2checkout SID  (Seller ID) of the 2checkout account he would like to use to charge the users on the 
website. The seller id can be obtained from the 2checkout website (during a new registration for the 
new users) or from the admin panel for the registered ones.

 
Cheques address 
In this field the administrator has to enter the address, which has to be used for the cheques to be 
sent if the cheques payment options is enabled on the website.

 
Bank account information 
In this field the administrator has to enter the full information for the bank account to be to be used 
when the bank transfer payment option is enabled on the website.

 
Amazon Payments ID, PayFast ID, InterKassa ID, Google Checkout ID, Skrill/Moneybookers ID ,  
PayMate ID
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To enable any of the following system in order to charge the users, it's enable to enter your ID for them 
in the corresponding text fields on the Configuration Options pages.
If you wish to disable any the systems in the future, it's necessary to simply delete the corresponding 
ID.
 
SEO text to be appended to the category page title 
When clicking on a category, the default page title will be the category name. By adding custom text in 
this field, you can customize the titles of the category pages, which will be then the Category Title + 
Your Text (so in this way you can create unique titles for better search engines optimization).

 
SEO text to be appended to the category page meta description 
By adding  a  text  in  this  field,  you  can  add  a  text,  which  will  be  appended  to  the  default  meta 
description for SEO purposes. 

 
SEO text to be appended to the category meta keywords 
By adding a text in this field, you can add a text, which will be appended to the default meta keywords 
for SEO purposes. 

 
Website date format string 
By entering a valid PHP date format string, you can change the format of the date displayed on the 
website.
Full information on the supported date format strings can be found on:
http://www.php.net/manual/en/function.date.php

Here are a few examples:
"F j, Y, g:i a" // March 10, 2001, 5:16 pm
"m.d.y" // 03.10.01
"j, n, Y"  // 10, 3, 2001
"H:i:s"  // 17:16:18

Enable Facebook Login, Facebook APP ID, Facebook Secret
Using these settings,  you can enable the Facebook log in  feature on the front  site  and set  your 
Facebook APP ID and Secret (it's a Facebook requirement to register your website with them and get 
an application ID and secret before the log in system could be used on your website).
Please visit our the online knowledge base in the support section of our website to find a visual guide 
on how you could register your site on Facebook and get an application ID and secret

2.2.  Setting the website pricing plans and subscriptions

The software allows to create different listing packages – free and paid that can differ on their price,  
and featured status (the featured listings show up with different background color, always on top of 
their categories and also randomly in the Featured Ads section to the right).

The new packages can be added from the Ads Management → Packages page, by clicking on the 
Add a new package at the top of the page. 
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When creating a new package, it's  necessary to enter his name and description, price and if  the 
package offers  featured status etc.

The description  shows up on the front  site  to  the user  and helps  him select  a  package,  so  the 
administrator can explain with it the advantage of choosing a paid package (like for example that when 
the ad is featured it will have better exposure etc.).
The field Active with possible values YES or  NO allows to temporarily  deactivate  a package (for 
example if you temporarily don't wish to offer paid packages) or activate again after some time.

2.3. Vehicle types and fields

The Car Portal comes by default with the Cars, Motorcycles and Trucks vehicle types defined and with 
a feature allowing you to define additional ones from the Settings->Vehicle Types page.

The name of the new vehicle type could be written for example like “Cars” or “{CARS}” - the second 
option can be used when the website is multi language, it tells the system to search the word CARS in 
the language file (so it will different when the language changes), while when using the first, it will be 
“Cars” for all the languages.
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For every vehicle type, you can define the makes and models, the additional fields and features.
The features can be set as a list, one per line, for example for the Cars vehicle type the default ones 
are:

Air Conditioning
ABS
Alarm
AM/FM Radio
Alloy Wheels
Auxiliary heating
Bucket Seating
Cassette Radio
Central locking 
CD Player
Cruise Control
Driver-Side Airbag
Electric heated seats
Electric windows
ESP
Extra Cab
Four wheel drive 
Full Service History
Immobilizer 
Leather Interior
Memory Seats
Moon Roof
Navigation system 
Passenger-Side Airbag
Parking sensors
Power Lock
Power Seats
Power Steering
Power Windows
Rear Air Conditioning
Remote Alarm Control
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Rear Window Defroster
Rear Window Wiper
Side-Impact Airbags
Sun Roof  
Taxi
Tinted Glass
Tow Package
Xenon headlights 

Clicking on the MAKES AND MODELS icon for a selected vehicle type, will open the page for editing 
them.

If leaving the Models field empty, then no drop down menu with the models will  show up for this 
vehicle type but a simple text field allowing to enter the model (when posting a new listing) or search in 
the posted listings.
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3. Administration panel

When creating the software, we strove to design and create an administration panel, which is as user 
friendly as possible and gives quick access to all the settings and ads management pages.
The administration panel is responsive and mobile friendly (adapting to the different screen sizes) and 
is also using tiles to make easier working with it when using touchscreens. 

3.1. General overview

The administration panel is the main tool available for the Car Portal website administrator to manage 
the website, change its settings, pages content etc.

The features in the admin panel are divided in categories. The main administrator and the members of 
the Administrators group have access to all the categories and pages in them. 

The Car Portal administration panel functionality is divided in 8 categories / menus in the main start 
menu: 

- Home (welcome / dashboard page, modification of password, log in report) 
- Real Estate (management of the listings, packages and options) 
- Settings (management of the locations, configuration options and others) 
- Payments (subscriptions, private sellers packages and credits system management) 
- Website (front site structure and content management, navigation menu settings) 
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- Extensions (custom extensions and extension files and different modules) 
- Templates (front site templates management) 
- Statistics (reports and referrals for the website visits) 
- Admin Users (management of the administration panel users, groups and permissions) 

The dashboard (home page of the administration panel) has a welcome message to the administrator, 
shortcuts / tiles to the main pages and quick overview of the last posted listings.
These shortcuts can be easily customized to create shortcuts to the pages you plan to use more often. 
In order to create a new page shortcut, simply drag the menu item (corresponding to the page for 
which you wish to create the new shortcut) and release it over the position in the dashboard you 
prefer, as shown on the screenshot below. 

This will replace the existing shortcut with the new one you created. The new tiles will be saved and 
the next time you log in, you'll will be able to go to the page by clicking on the tile. Tiles are also great 
if you use the admin panel with a tablet or smartphone, because they are easy to see and click on 
touchscreens. 
You may also easily change the position of two tiles, by dragging and releasing a selected tile over a 
new position, as shown on the screenshot below. 
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3.2. Main pages in the administration panel

You may find below a quick overview and brief information about the most used pages in the 
administration panel and functionality on it.

Home → Welcome

The Welcome page in  the administration  panel  provides  quick information about  the new listings 
waiting to the approved and statistics, as well as links to the main pages in the administration panel for 
easier navigation.
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Home → Log in Report

The log in report shows a log of the administration panel log in attempts – the successful and failed log 
ins with their date and IP address.

Home → Change Password

This page can be used to change the password of the user for the administration panel. To change the 
password  it's  necessary  to  enter  the  old  password  and  the  new one  and  confirm  it  –  after  the 
password is changed successfully, the user will be logged out and asked to log in again with his new 
password.
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Real Estate → Approve Ads,  Real Estate  → Current Ads

The Approve and Current Listings pages can be used to manage the new and existing listings on the 
website, approve, delete or modify them.

Real Estate → Users

From this page, the administrator can see and edit the registered users on the website.
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Settings → Configuration Options 

The page has many different options that you can use to configure your website in the way you prefer 
– set your timezone and currency, configure the preferred payment options and many others. Please 
find detailed description of the different settings in “2. Configuring the website”

Settings → Property Types

This page makes possible for the administrator to add new property types, delete any of the existing 
ones and manage the fields and property features for the different property types.
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Settings→ Locations

The page can be used to modify the locations showing up on the front site (on the Browse by Location 
page and also on the page for submitting new ads).

Settings → Language Versions

If you would like to run a multi language website, it's necessary to add the additional languages from 
this page in the administration panel. Please note when you a add a new language, it's necessary to 
upload  also  the  language  file  for  it  in  the  /include  folder  on  your  website.  Please  refer  to  the 
“Languages  and  language  files”  for  more  information  and  description  of  the  language  files  and 
languages management.

Website → Management
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This is the main page to be used to manage the website structure and content – add new pages,  
remove or rename the current ones, modify the pages content, the page title meta keywords or meta 
description or set custom php extension to be executed for a page.

Website → Navigation Menu

Modifying the menu item template from this page can be useful when customizing the website look 
and feel or when integrating a custom design / front site template.

Website → Manage the forms

The custom server side forms can be useful if you would like to create custom contact or feedback 
forms or any other type of forms to get information or inquiries from the users. When creating a new 
form you can add in it the fields you prefer – it's possible to create text fields and drop down menus by 
entering the possible values for them.
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The data sent by the users can be seen from the administration panel and / or to be forwarded to an 
email  address  set  by  the  administrator  (the  email  address  and  message  that  will  be  shown  on 
successful form submission can be set when clicking on the Settings icon for a selected form).

Website → Posted Data

The page shows the data posted by the users from the custom server side forms (like the Contact 
form on the website). You can also choose this data to be forwarded to an email address you prefer, 
from the Settings page of the form.

Extensions → Files

The page shows the current files in the /extensions folder, which can be used for extensions of the 
pages or custom tags. Please note that files that should be used for custom tags have _tag at the end 
of  their  name.  A file  can  be  set  to  be  executed  as  extension  for  a  page  from  the  Website  → 
Management page and for a tag from Extensions → Tags
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Extensions → Tags

You can use this page to see the current tags, delete any of them or add new tag. Please check the  
chapter “Custom Tags” to read more about their usage and functionality.

Extensions → News, Extensions → FAQ Manager, Extensions → Newsletter

These are some basic modules loaded by default from sour site manager content system allowing to 
post news on the website, create a page with frequently asked questions and send newsletter to the 
users who have subscribed for it.
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Templates → Modify, Templates-> Select a Template, Templates → Add a New Template

These pages can be used to modify the front site template, select a different template or add a new 
template by pasting its HTML code. 

For more information about the templates and their structure, please check the section “Templates 
Management' in this manual.

Statistics → Reports

The page shows brief information about the website visits and also displays a chart for them.

Please note that the integrated website visits tracking and statistics information is basic and simple, for 
more  advanced 
tracking  and 
information,  we 
recommend 
using an external 
system  such  as 
Google Analytics, 
which  can  be 
easily  added  on 
the website.
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Statistics → Referrals

You can see on this page the last referrals, so you can easily track who is linking to your website and 
from where the traffic to your website comes from.

Users → User Groups, Users → New User, Users → User Permissions

Using these pages, you can add new administrator users to your website, put them in groups and set 
their permissions. This can be useful if you would like to have multiple users working on the website 
with permissions limited to just some selected pages. For example have a News Administrators group 
with permissions to access only the News Management functionality in the administration panel etc.
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4. Website structure and content management

The functionality, different menus and options on the Website → Management page allow the 
administrator to manage the website structure – add new pages, rename or remove the existing ones 
etc. and also manage the content of the website, edit the content of the different pages, set extensions 
to be executed for them and others.

4.1. Structure management, adding new pages

Changing the front site pages meta title and description
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In order to change the front site pages meta title, keywords or description, the administrator has to log 
in in the admin panel and go to the Website->Management page. 
On this page, he will see the available website pages as a tree. He  has to left click with the mouse on 
a  page in  order  to  select  it  and then choose from the Context  menu which will  show up “Page 
Settings”.

A new page will show up containing various page fields including also the page meta title description. 
The administrator has to enter the new values and click Save.

Adding new pages to the website

The Car Portal admin panel offers  the possibility to freely edit the website structure – add, edit or  
delete the pages  of the front site.

Please  note  that  you  need  to  define  the  website  structure  separately  for  the  different  language 
versions available (you could switch between the language versions by selecting the language from 
the big drop down menu at the top of the Website → Management page).
In order to add a new page to the front site you need to click on the New Page button at the top of  
Website → Management

This will enter the form for adding a new page - 

Car Portal is a product of NetArt Media  www.netartmedia.net , All rights reserved

http://www.netartmedia.net/


with the following fields:

- Link Text , the name of the link, which will show up in the main navigation menu
- Page Type, it can be either a main page or a sub page of an already existing page
- Title, the title of the page, which will show up in the title tag
- Meta Description, the meta description of the page, which will appear in the meta description tag to 
be used for search engines optimization purposes
- Meta Keywords, the meta keywords of the page, which have to be entered as a list and will appear 
after that in the meta keywords tag on the page, to be used for search engines optimization purposes

Changing the pages hierarchy

You can modify the front site pages hierarchy by clicking on the Change Hierarchy button at the top of 
Website → Management  using the form at the bottom of the Website->Management page.7

This will open the change hierarchy form - this form there allows to make a page of the website either 
a main page or a sub page of an existing main page.
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Changing the position of two pages

By changing the position of 2 pages, you'll change the order of the pages in the main navigation menu 
(for example replace the positions of the Home and About us pages).

Near every page on the Website->Management page, you could see 2  arrows indicating the up and 
bottom directions, you have to click on them in order to change the position of the pages.

Please note that you can change the position of 2 pages only if they are on the same level in the  
website hierarchy (for example main pages, or sub pages of the Home page etc.)

4.2. Modifying the content of the pages

The content of the pages can be modified from the Website->Management page in the admin panel. 
On this page, the administrator see the pages as a tree.

If the website is multi language, you need to choose the language version to manage by using the 
drop down to the left on Website → Management - this will switch between management of the pages 
of the different language versions. 

Please note that if you would like to modify the content of a page and the website is multi language, 
you need to do this for every language. For example modify the “Contact” page in the English version, 
then the “Contacto” page in the Spanish version etc.

To edit the content of a page like for example the Contact us page, the administrator has to click on it  
and then choose either “Launch WYSIWYG editor” or the “Edit HTML code” option. 
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When using the Edit the HTML code option, you will be able to directly modify the html code of the  
page, while with the first (Edit the page), a WYSIWYG (what you see is what you get) editor will open, 
allowing to modify the content of the page.

Please note that the pages for which php files are set to be executed (the “Set Custom Extension” 
option) can't be modified directly with the WYSIWYG editor. These pages can be easily distinguished 
on the Website->Management page, near their name one could see with red font the name of the php 
file to be executed, for example for “Latest Links”  this is “latest_links.php”.
The reason is that the code for these pages is rendered by the system, for example in the case of the 
Latest Links page, it's generated by the file /extensions/latest_links.php (which is the jobseekers sign 
up form), so the php code for it can't be modified with the WYSIWYG editor.

The page can be modified by editing directly the file for it or if only some texts need to be changed, 
this may be done by modifying the language file (/include/texts_en.php for English).

4.3. Website navigation menu

To give maximum flexibility to modify the style of the front site menu, the administration panel provides 
also an option to edit  the menu item template from the Website → Navigation Menu page in the 
administration panel.

In this template [LINK_TEXT] will be replaced by the text of the link (page name) as set by the 
administrator on the Website → Management page and [LINK_HREF] with the link to the page 
(generated by the script).

4.4. Custom server side forms

The custom server  side forms functionality is  a  feature  allowing the administrator  to  create  and 
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publish on the front site forms (such as contact forms) with custom fields defined by the administrator. 
Adding a new custom server side form can be done on 2 steps - the first one is to enter the form name 
and a brief description and the second one is to add the form fields. For every field the administrator 
should specify its name, type, the text displayed near it, its size and if it's an obligatory field (available 
only for some of the fields) and the message which will show up if the user leaves empty an obligatory 
field. 
The new forms can be added from the Website → Manage the forms page and then clicking on the 
New Form at the top.

while the existing forms can be managed from the Tools → Manage the forms page in the admin 
panel.

The forms can be deleted, modified, copied (in order to copy forms on different pages on the front site) 
and also their settings can be modified.
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The settings that can be modified are:
– the form name (the name can be 

used for identification of the form, 
by default it doesn't show up on the 
website)

– the form description
– the text, which will show up on the 

submit button (like “Send” or 
“Enviar” etc.)

– message displayed after the user 
has successfully submitted the form

– and also the email to which the 
forms data will be sent, the 
administrator can fill in this field his 
preferred email address to which 
the data sent by the users will be 
forwarded (it will be also available in 
the admin panel on the Tools → 

Posted Data page)

4.5. Languages and language files

The language files contain the text and words shown on the user interface. For every language there 
is one language file located in the /include folder.
The name and location of the language file is: /include/texts_[CODE OF THE LANGUAGE].php
or for example /include/texts_en.php for English. The language file contains the different messages as 
PHP variables, for example:

$M_HIDE_RECENT_SEARCHES="hide recent searches";
$M_CLEAR_ALL="clear all";
$M_SEE_ALL="see all";
$M_WEBSITE_HOME="Website Home"; 
…

Translating the language file consists of translating the messages enclosed in brackets to the right, for 
example for Spanish:

$M_HIDE_RECENT_SEARCHES="ocultar búsquedas recientes";
$M_CLEAR_ALL="borrar todos";
$M_SEE_ALL="ver todos";
$M_WEBSITE_HOME = "Sitio Web - Inicio";

In order to add a new language on the website, it's necessary to add the translated file in the /include 
folder and also the administrator has to use the form on the Settings → Language Versions page and 
enter the name of the new language for example “Deutsch” and the code for the new language, for 
example “DE”. 
The language code shows up after in the page links and is also used to for the name of the language 
file (in this case the language file will be /include/texts_de.php) and it's important to be 2 characters 
(like EN, DE, PT, TR etc).
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5. Front site templates management

5.1. Templates overview

A  template  for  the  front  site  represents  a  standard  HTML  code  mixed  with  some  special 
WebSiteAdmin tags (the compatibility with the WebSiteAdmin template system, makes possible the 
usage of templates and features from other products using it, as well as combining different scripts 
and software products to work on one website). 

A front site could be either set as a file called “template.htm” in the main website folder or it can be set  
from the administration  panel  and  the Templates  → Modify  page.  If  both  are  available,  then the 
template saved as a file “template.htm” will be used (it has higher priority).

You may fine below a brief description of the template system and tags and check also 6.3. Custom 
HTML tags to see how you may create also your own custom tags with custom php files and code 
executed for them.

When the different page are rendered on the front site, these special tags inserted in the template are 
replaced by the corresponding content - let's consider the following example with a simple template:

<html>
<head>
<meta>
<title><site title/></title>
<meta name="description" content="<site description/>" />
<meta name="keywords" content="<site keywords/>" />
...

When the page is rendered, for example the tag <site title/> will be replaced with the page title (in 
general the page titles can be set by the administrator from the Website → Management page), so 
<title><site title/></title> will become:
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<title>The page title will come here</title>

Please note that presence of none of these tags is obligatory, so you could combine them as you wish 
in order to create the website and layout suiting the best your specific needs. Be aware also that 
WebSiteAdmin allows you to create your own tags (from the “Custom tags” in the back office) and set 
php files created by you to be executed and the generated content to be used in real time to replace 
the tag with it.

Here are some most common tags used in the default templates of the different scripts based on 
WebSiteAdmin:

<site title/> - Title of the web page 
<site description/> - Meta description of the web page 
<site keywords/> - Meta keywords of the web page 
<site menu/>- Main navigation menu of the website 
<site languages_menu/> - The languages menu of the website 
<site content/> - The main content of a page 
<site form/> - The custom server side forms for this page if there are any 
<site logins/> - The main log in form of the website
<site quick_search/> - The quick search form on the front site
<site news/> - The news (the administrator can manage them from the News page in the ADMIN)
<site featured_ads/> - The block displaying the featured ads
<site bottom_menu/> - The bottom menu displayed at the bottom of the site (it contains the same 
items as the main navigation menu)

Please note that depending on the current product or script you are using, not all these tags may be 
available on it.

To see your current template, the tags in it or modify it, please go to Templates in the administration 
panel.

5.2. Adding new templates and modifying the existing ones

In the Car Portal administration panel you may find the following pages related to the front site 
templates management:

Templates → Select a Template
The page offers the possibility to the administrator to select a template which will be used for the front 
site between the currently available templates. Please note that in order to be able to select a template 
for a given website, you need to add first the template (if it doesn't still exist)

Templates → Add a New Template
This page can be used to add new templates to the website. The administrator can add the new 
template by directly pasting its HTML code.

Templates → Modify

On this page the administrator can see the available templates and modify a selected template. In 
order to select a template for modification, the administrator should click on the Modify icon and then a 
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new text area having the full template code will appear.

5.3. Custom HTML tags

The custom HTML tags provide a great way to expand the current functionality by creating your own 
php scripts to be executed and the content they output to be shown precisely in a selected position by 
the administrator.
This can be for example a php script calendar_tag.php showing a custom calendar, which needs to be 
added at the top right corner of all pages of the website.

Creating a new custom tag is simple - the first step is to upload the corresponding PHP file in the  
/extensions folder on your site. 
Please note the file names of php files, which will be used for tags should end with tag in their name – 
for example calendar_tag.php or news_tag.php etc.
Then from the Extensions → Tags page in the administrator panel, fill  the tag name (for example: 
calendar) and click on the Add button. This will create the tag - <site calendar/> in this example and it 
will appear on the Tags page.

The tag should be defined from Extension → Tags and then inserted in the template or in the page 
content.  When the page is  rendered all  the custom defined tags will  be  replaced by the content 
generated by the script you set. 
The Tags page shows the current tags with their name, html code, the file to be executed (with a drop 
down listing all the uploaded tag files in the /extensions folder and a small delete icon allowing to 
delete the tag).

The final step when creating a new tag is to associate your tag with the php file you uploaded – this 
can be done by simply selecting the file from the File dropdown (“calendar_tag.php” in this example) 
and click on the Save button at the bottom of the page.
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After doing this, you can start using the tag by inserting it in the front site template (from Templates → 
Modify page) at the position you prefer in the template. 

5.4. Adding Google AdSense advertisements or Google Analytics

Very often the administrator may need to add external HTML code on website, it can be for example 
the HTML code for Google AdSense or other type of advertisements or Google Analytics code or a 
code provided by Google WebMaster Tools to verify the website.

Such HTML codes need to be pasted in front site template, which can be done from the Templates → 
Modify page in the administration panel. On this page, it's necessary to click on the Modify icon – this 
will show the HTML code of the template and paste the piece of HTML code for the banners, Google 
Analytics or similar.

When adding a counter or other tracking code like Googl Analytics, usually the best it to place it at the 
end of the template, for example just before the closing </body> tag.

For the advertisements the position will depend on what position exactly in the template (for example, 
top or bottom or to the right of the website pages etc.) the administrator would like to add them.

If you experience any difficulties when doing this, please don't hesitate to contact us and our support 
team will try to assist you asap.

6. Administration panel users and groups

The administrator has the possibility to create additional user groups for the main administration panel, 
add users in them and assign their permissions. This can be done from “Users” in the administration 
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panel.

This functionality can be used if for example there are multiple persons working on the website (for  
example person A validating the listings posted by the users, person B responsible for the design of 
the website and templates management, person C adding news on the website etc.)

6.1. User groups

The user groups make easier the permissions management for the users – instead of setting 
individually the permissions for every users, it can be be possible to create different user groups, add 
the users in them and manage the permissions per group.
For example, it can be possible to create a group of users who will be responsible only for posting 
news on the website “NewsAdministrators” and won't have access to the other pages like the ones for 
validating the listings etc.

To create a new user group, the only field the administrator has to fill is the group user name.

The page shows below also the list of the groups with their ID and a check box allowing to select one 
or many groups and delete them.
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6.2. Adding new users

To add a new user, it's necessary to click on the New User button at the top of the User Groups page 
or choose directly from the main start menu Users → New User.

When adding a new user, it's necessary to select its Type or User Groups between the ones added by 
the administrator, enter his username, password, phone and email.

To see a list of the current users or modify their information, it's necessary to go to the Users List page 
(can be selected from the start menu Users → Users List or using the top buttons while in the Users 
category in the administration panel)

6.3. Permissions management

To set  the  permissions  for  the  different  user  groups,  it's  necessary  to  go  to  the  Users  → User 
Permissions page in the administration panel.
The page shows a list of all the pages available by default in the  administration panel and a check 
box for every box – to grant a permission for a selected page, it's necessary to check the box for it and 
when when ready, to click on the Save button at the bottom of the page.
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This will save the permissions sets for the user group.

An user,  member  of  an user  group,  which has been granted access to  only  some pages in  the 
administration panel will see just these pages in the menus when he logs in.
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